Welcome! Log In Create A New Profile

Advanced

Problemas de compatiblidade: Spring5_3_Port_Ubuntu1404_x64 & Ubuntu 16.04 LTS

Posted by ricardo_emidio 
Problemas de compatiblidade: Spring5_3_Port_Ubuntu1404_x64 & Ubuntu 16.04 LTS
April 28, 2016 07:19PM
Olá queridos colegas,

Estou iniciando a jornada Spring no Linux na distribuição do Ubuntu 16.04 e ao proceder as instruções de instalação descritas no ajuda + descrições em tópicos anteriores encontrei um problema de imcompatibilidade entre os Qts: 4.87 do SO e 4.8.6 do Spring. Há alguma maneira de solucionar este problema?


Agradeço antecipadamente qualquer ajuda!
Grato,
R. Emidio

Abaixo segue o resultado do comando no terminal


./s_spring
liblibspring.so.1
libliblegal.so.1
liblibimp.so.1
liblibshapefile.so.1
libqwtplot3d.so.0
liblibgps.so.1
libsg.so.1
libsgd.so.1
libliblua.so.1
liblibtolua++.so.1
liblibtiff.so.1
liblibz.so.1
liblibkml.so.1
liblibjpeg2000.so.1
liblibglobal.so.1
libtracer.so.1
libgeos-3.4.2.so
liblibchart.so.1
libterralib331.so.1
libtepdi.so.1
liblibfreetype.so.1
liblibdwg.so.1
libocci.so.12.1
libclntsh.so.12.1
libnnz12.so
libclntshcore.so.12.1
libociei.so
libons.so
libmql1.so
libipc1.so
libmysqlclient.so.18
Cannot mix incompatible Qt library (version 0x40807) with this library (version 0x40806)
./s_spring: linha 57: 6713 Abortado (imagem do núcleo gravada) $executavel
Re: Problemas de compatiblidade: Spring5_3_Port_Ubuntu1404_x64 & Ubuntu 16.04 LTS
August 31, 2016 04:37PM
Ricardo, boa tarde!

Tive um problema e similar e encontrei sua mensagem. Embora você não deva mais estar precisando, vou postar a solução que obtive para referência futura.

Basicamente eu troquei as bibliotecas libQt* fornecidas no pacote do Spring pelas do sistema, que são atualizadas (Ubuntu 16.04). Supondo o diretório de instalação "Spring53", segue a sequência de comandos...

cd Spring53/
ls sharedlibs/libQt* -1 | xargs -n 1 basename > libQt_ori.txt
cat libQt_ori.txt
tar cfkvz libQt_ori.tar.gz sharedlibs/libQt*
cat libQt_ori.txt | xargs -n 1 apt-file search
rm sharedlibs/libQt*
for i in $(cat libQt_ori.txt); do cp /usr/lib/x86_64-linux-gnu/$i sharedlibs/$i; done
rm -rf shared
./s_spring
Re: Problemas de compatiblidade: Spring5_3_Port_Ubuntu1404_x64 & Ubuntu 16.04 LTS
July 25, 2017 10:28AM
Pessoal bom dia,
Gostaria de saber se alguém pode me ajudar?
Estou fazendo a interpretação deuma imagem Ikonos referente a uma área de 98 km2.
Estou fazendo isso há 15 dias.
Agora a pouco eu estava interpretando a imagem e o Spring 5.4.3 (Ubuntu 16.4) fechou sozinho, como outras vez. Entretanto nesta vez sumiram todas as linhas já realizadas (por volta de 70% da imagens).
Alguém sabe como recuperar isso?
Obrigado pela atenção de todos.
Gustavo
Sorry, only registered users may post in this forum.

Click here to login