Welcome! Log In Create A New Profile

Advanced

Spring 5.1 no linux Puppy 4.1

Posted by pquina 
Spring 5.1 no linux Puppy 4.1
July 27, 2009 09:43PM
Estou tentando instalar o Spring versão 5.1 no linux Puppy versão 4.1, para facilitar o uso dos alunos pela Faculdade onde leciono, pois utilizaremos no VMWare Player.

Como não encontrei um download para uma versão genérica, fiz o download para instalação no Ubuntu 8.10.

Após descompactar o arquivo em /usr/local foi criado o diretório "Spring5_1_Port_Ubuntu810_x86".

Ao executar o "./spring", obtive o seguinte erro :

./spring: error while loading shared libraries: libpq.so.5: cannt open shared objct file: No such file or directory

Então adicionei o caminho "/usr/local/Spring5_1_Port_Ubuntu810_x86" a variável de ambiente LD_LIBRARY_PATH.

Ao executar o "./spring", obtive o seguinte erro :

./spring: /lib/libz.so.1: no version information available (required by ./spring)
./spring: /lib/libc.so.6: version 'GLIBC_2.7' not found (required by ./spring)
./spring: /lib/libcrypto.so.0.9.8: no version information available (required by /usr/local/Spring5_1_Port_Ubutu810_x86/sharedlibs/libpq.so.5)
./spring: /lib/libssl.so.0.9.8: no version information available (required by /usr/local/Spring5_1_Port_Ubutu810_x86/sharedlibs/libpq.so.5)
./spring: /lib/libc.so.6: version 'GLIBC_2.8' not found (required by /usr/local/Spring5_1_Port_Ubutu810_x86/sharedlibs/libgnutls.so.26)

O que mais é necessário para executar o "./spring" ?

Obrigado

Pedro Quina
Re: Spring 5.1 no linux Puppy 4.1
July 28, 2009 04:35PM
Olá

Eu baixei a versão 4.3.3 e funcionou normalmente após descompactar.

Se alguém souber como fazer funciona ra versão 5.1 e puder dar uma ajuda.


Desde de já agradeço.


Obrigado

Pedro Quina
Re: Spring 5.1 no linux Puppy 4.1
April 05, 2011 11:21PM
Nao sei se ajuda o colega mas quando tentei rodar o spring 5.1 no ubuntu 10.10 apareceu a seguinte mensagem.

cp: não foi possível criar arquivo comum `./shared/libpq.so.5': Permissão negada

Resolvi o problema inicializando com o comando super usuário.

Assim digitei no terminal

sudo ./s_spring

E rodou legal!!!
Sorry, only registered users may post in this forum.

Click here to login